Typ MIME
Media type, typ MIME[a], Content-Type – dwuczęściowy identyfikator formatu danych przesyłanych w Internecie. Oryginalnie zdefiniowany w RFC 2046 ↓ do użycia w ramach nagłówków poczty elektronicznej. Z czasem rozprzestrzenił się na inne zastosowania i protokoły jak HTTP czy SIP. Rolą tego nagłówka jest umożliwienie programowi użytkownika dobrania odpowiedniego programu potrafiącego obsłużyć przesłany przez serwer zasób[2].
Podstawowa forma identyfikatora składa się z dwóch części: typu i podtypu rozdzielonych znakiem ukośnika, którym mogą towarzyszyć opcjonalne parametry. Podtypy typu text posiadają np. opcjonalny parametr charset używany do wskazania kodowania znaków, a podtypy dla multipart często definiują parametr boundary jako separator poszczególnych części[2]. Typy lub podtypy zaczynające się od „x-” są traktowane jako niestandardowe i jako takie nie są rejestrowane w Internet Assigned Numbers Authority (IANA)[3]. Podtypy zaczynające się od vnd. należą do prywatnych rozszerzeń dostawców[4].
Przykłady popularnych typów
IANA utrzymuje rejestr identyfikatorów typów wraz z rejestrem identyfikatorów kodowań znaków. Lista ta jest dostępna w Internecie.
Przykłady:
- Typ
text– dane tekstowe czytelne dla człowieka:text/plain– prosty tekst[5][6],text/css– kaskadowy arkusz stylów[7],text/html– HTML, język opisu stron hipertekstowych[8],text/xml– XML, rozszerzalny język znaczników[9],
- Typ
application– pliki specyficzne dla programów:application/octet-stream– dowolny strumień bajtów. Jest to „domyślny” typ używany często do oznaczenia plików wykonywalnych, plików nieznanego typu lub plików, które powinny być pobrane protokołem nie obsługującym odpowiednika nagłówka „content disposition”. RFC 2046 ↓ definiuje ten typ jako typ awaryjny dla wszelkich nierozpoznanych podtypów[5].application/javascript– kod języka JavaScript (oryginalnietext/javascriptobecnie przestarzały)[10],application/json– JSON, obiektowa notacja JavaScript[11],application/ogg– Ogg, kontener multimedialny[12],application/xhtml+xml– XHTML[13],
- Typ
audio– dane audio:
- Typ
image– obrazy cyfrowe:
- Typ
multipart– archiwa i inne obiekty składające się z więcej niż jednej części:
- Typ
video– formaty wideo:
Zobacz też
Uwagi
- ↑ Od skrótu ang. Multipurpose Internet Mail Extensions zdefiniowanego w RFC 2045 ↓[1].
Przypisy
- ↑ Internet Media Type registration, consistency of use [online], W3C, 3 czerwca 2002 [dostęp 2006-11-29] (ang.).
- ↑ a b RFC 2045 ↓, s. 10–11.
- ↑ RFC 2045 ↓, sekcja 6.3, s. 15.
- ↑ RFC 2048 ↓, sekcja 2.1.2, s. 3–4.
- ↑ a b c d e RFC 2046 ↓, s. 5, 11–13.
- ↑ RFC 3676 ↓, s. 1–20.
- ↑ RFC 2318 ↓, s. 1–2.
- ↑ RFC 2854 ↓, s. 2.
- ↑ RFC 3023 ↓, s. 5–7.
- ↑ RFC 4329 ↓, s. 8–12.
- ↑ RFC 4627 ↓, s. 6.
- ↑ RFC 3534 ↓, s. 2.
- ↑ RFC 3236 ↓, s. 2.
- ↑ RFC 3003 ↓, s. 2.
- ↑ MIME Type Settings for Windows Media Services. Microsoft, 2003-11-03. [dostęp 2023-07-28]. [zarchiwizowane z tego adresu (2012-12-08)].
- ↑ W3C PNG Working Group: Media type name: image / Media subtype name: png. 2021-12-07. [dostęp 2023-07-28]. (ang.).
- ↑ RFC 3302 ↓, s. 3.
- ↑ Simon Butcher: MIME media type name : Image / MIME subtype name : Vendor Tree - vnd.microsoft.icon. 2003-09-03. [dostęp 2023-07-28]. (ang.).
- ↑ a b RFC 2046 ↓, s. 24–26.
- ↑ RFC 2387 ↓, s. 1–8.
- ↑ RFC 4337 ↓, s. 3–5.
- ↑ Paul Lindner: Registration of new MIME content-type/subtype. 1993-06-04. [dostęp 2023-07-28]. (ang.).
- ↑ Microsoft KB 288102